Cómo excluir un paquete determinado al actualizar el sistema

Muchas veces sucede que estamos más que satisfechos con la versión de un determinado programa, o es más, por motivos de fuerza mayor, nos vemos forzados a conservar cierta versión para evitar que se rompa alguna funcionalidad en el sistema. Digamos que al actualizar QT5 se rompe nuestro servidor virtual Webmin que requiere QT4, por lo que para actualizar el sistema, necesitaríamos retener solamente el paquete QT5.

Para evitar que el sistema actualice in paquete específico, corre en la terminal:

sudo apt-mark hold nombre-del-paquete

El paquete especificado quedará retenido y no será actualizado hasta que se corra la siguiente orden:

sudo apt-mark unhold nombre-del-paquete

Hecho esto, el paquete que anteriormente se había retenido, será liberado y actualizado la siguiente vez que se actualice el sistema o se actualice de manera individual.

Si quieres actualizar un paquete de manera individual, puedes ver esta otra guía que enseña como cómo actualizar una aplicación especifica en Debian y derivados.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *