Los siguientes paquetes han sido retenidos [SOLUCIÓN]

Compartir:

El mensaje de error “Los siguientes paquetes han sido retenidos:….” se produce, cuando luego de una actualización, el conjunto de paquetes mostrados por el error (una lista cuyo tamaño varía), requiere de dependencias que no van a instalarse (no pueden satisfacerse). Dicho en otras palabras, los paquetes retenidos, requieren de versiones más recientes que aquellas que corren actualmente en el sistema, y como no se ha especificado una actualización completa, se retienen.
La solución es bastante sencilla, pero tienes que notar la orden que se muestra a continuación actualiza TODO el sistema (paquetes, kernel, plugins, etc.) a las versiones más recientes disponibles en los repositorios de tu distribución con las consecuencias que ello acarrea. Esto puede incluir muy seguramente algunos de tus paquetes preferidos (que pueden en sus nuevas versiones perder cierta funcionalidad) y actualizaciones a de núcleo (Kernel) que podrían dejar inservible cierto componente en tu ordenador (viejas tarjetas de vídeo o WIFI por ejemplo).

sudo dist-upgrade

Luego, es muy probable que termines con una lista de paquetes y dependencias que ya no son necesarias en tu sistema. Para removerlos, corre:

sudo apt autoremove

Eso es todo. Espero que les sea de utilidad.
Saludos!

Compartir:

Responder

Web
Analytics Made Easy - StatCounter